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1 Aerial Photography Spatial Index Application Overview 
 
The Aerial Photography Spatial Index (APSI) is an ESRI ArcMAP project.  ArcMap is an 
application that allows the user to geographically view a dataset’s information while also being 
able to interact with the data from the dataset’s table and add layers to generate electronic or 
hardcopy maps.  Having datasets interlinked between a “visual” and a “table” enable users to 
find their imagery quickly through either spatial or tabular searches/queries.  In the case of 
opening APSI, the user will visually see where aerial photography is available.  The user will 
learn how to access all the available linked dataset tables. These tables are useful to gather, 
query, or select information regarding the aerial imagery the user may want. 
 

2 Connecting to the Aerial Photography Spatial Index (APSI) 
 

1. Login to the APSI – Type the web address https://citrixnr.blm.doi.net into Internet 
Explorer.   

a. Note: You need to have the Citrix ICA Client installed on your local workstation 
and have permission to login to the APSI.  Requests can be made to your Help 
Desk for both items.  You will be notified via email when you have permission to 
access the APSI. 

2. Enter your Windows username and password in the ‘Log in’ page.  
3. Click the ‘Aerial Archive’ on the ‘Applications’ page.     
4. A ‘Warning’ message will appear, Click ‘OK’. 

a. If everything is working correctly, an ArcMap dialog box will appear 
that indicates the APSI is loading.  If no ArcMap dialog box appears then most 
likely you do not have Citrix installed on your workstation.  Contact your Help 
Desk to have the Citrix client installed.   

b. Another indication that Citrix is not installed is if a dialog box opens asking you 
to save a file.  If this happens, Click ‘Cancel’ and contact your Help Desk. 

c. Note: First time users will encounter a reduction in performance time as 
preferences are loaded. Once initiated, response times are only a bit slower than 
for locally served data. 

5. ArcMap opens and you can start interacting with the data.  The default map view will 
look similar to the figure below.  Based on user settings there may be some variability in 
the number of icons visible in ArcMap.  The Map Window will always open to the same 
Western U.S. extent. 

https://citrixnr.blm.doi.net/


 
Opening screen to APSI 

 



3 APSI Quick Overview 
 
The APSI Quick Overview will briefly explain what a user will see upon first opening the APSI. 
Users not familiar with ArcMap are encouraged to continue reading below about ArcMap tools 
and ways to interact within the application. 
 
The APSI is read-only, which means that any changes the user makes to the map will not be 
saved to the layout or database. While working in the map, data can be saved locally by 
‘exporting’ layers and attribute tables to your local workstation.  The Citrix aerial archive 
application provides all the functionality of ArcMap such as information queries, changes to 
display parameters, and the creation of map plots. Other resource databases can be added to the 
ArcMap session and displayed along with the aerial archive data.  
 
When APSI opens there are three groups of datasets or “layers” that are turned on (indicated by 
the black checkmarks). The layers you see are 1) a view of the western U.S., 2) Aerial 
photography project boundaries, which are color coded by decade, and 3) National Geographic 
Society (NGS) interstate highways, jurisdictional boundaries, and several other layers. The 
grayed checked boxes to the left of the layer names are visible at larger scales.  At any time you 
can go back to the Western US initial extent by going to View>Bookmarks>Western US in the 
menu at the top. 
 
Additional aerial archive database layers are present and display at predetermined scales: 
 

• Flight lines display at a scale of 1:1,000,000 and are color-codes by project name  
• Photo Centers display at a scale of 1:400,000 
• Individual exposure labels display at a scale of 1:250,000 – The code for the labels are 

<Flight Line Number>-<Roll Number>-<Exposure Number>.  An example is 10-1-5, 
which is Flight Line 10, Roll 1, and Exposure 5. 

• A topographic base maps, streamed from a web service, provide a back drop at a scale of 
1:200,000 

 
The flight lines, photo centers, and project boundaries are all individual layers that are hosted by 
the BLM’s centralized EGIS database at NIRMC.  There are also four separate sets of layers 
BLM Admin Boundaries, Public Land Survey System, Surface Management, and NGS_Topo 
that are referred to as map services.  These map services are data hosted on other remote servers. 
The BLM Admin Boundaries, Public Land Survey System, and Surface Management services 
are served from GeoCommunicator and the NGS_Topo is served from ESRI.  Though the user 
cannot manipulate the symbology in a map service, the various layers that make-up the map 
service can be turned on and off. 



   

4 ArcMAP Concepts 

4.1 Map Window 
The Map Window is the area on the right-hand side of ArcMap that visually displays the 
“datasets” or layers. 

4.2 Table of Contents 
The Table of Contents is the area on the left-hand side of 
ArcMap that has a list of datasets.   

4.2.1 Layers 
The datasets in the TOC are called Layers. They are 
stacked one on top of another, are either “on” or “off” 
and contain the foundation to the APSI. 

4.2.2 Right-clicking Layers 
When you right-click on a Layer, you are given several 
options. These include “Open Attribute Table”, “Zoom 
to Layer” & “Properties”. 

4.2.3 Turning Layers On & Off 
Within the TOC, users can turn “Layers” on and off by checking the boxes to the left of their 
titles.  
If a layer has a grayed-out check box, that layer is only displayable in the Map Window at 
certain scales.  

4.2.4 Re-ordering Layers 
Users can place one layer on top of another by highlighting a dataset title and dragging it to the 
top of the list. 

4.2.5 Symbology & Expanding Layers 
To the left of each dataset title is a + or – sign declaring the dataset “expanded” or 
“contracted”. If the dataset has a minus sign next to it (Like AIRPHOTO.FLIGHTLINES) its 
symbology will be visible and explained. Once again, users can turn the expanded sub-datasets 
on and off by checking the boxes to the left of their titles. The fewer checked boxes, the faster 
your map window will refresh. 

4.3 Coordinates 
If you move your curser around and look at the bottom right corner of the screen, coordinates are 
displayed in degree, minutes and seconds. 

4.4 Map Service 
Map services are groups of map layers that are served from a remote location.  Users do not have 
control over the symbology for these layers, but can turn individual layers or the whole service 
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on or off.  As stated above, the APSI is using four Map Services to display reference content: 
BLM Admin Boundaries, Surface Management, Public Land Survey System, and NGS_Topo.  
These map services are included in the APSI to provide background spatial reference 
information in order to assist the user in locating the photography of interest. 
 

5 ArcMap Tools Quick Reference Guide 
 
Here is a short explanation of the icon tools you will need when using the Aerial Photography 
Archive Index Application. 
 

Zoom In – Enables users to zoom in based on a drawn box or point  

Zoom Out – Enables users to zoom out based on a clicked point 

Fixed Zoom Out – Zooms the map out by a factor of 2 

Pan – Enables users to move around the map 

Full Extent – Zooms to the maximum extent of the GIS layers 

Go To Previous Extent – Takes the user back to previous extent 

Go To Next Extent – Takes users forward an extent  

Select  Features – Enables users to ‘select’ features 

Select Elements – Not needed for this application 

Find – Enables users to search for data in the GIS Layers 

Measure – Enables users to measure distances and areas 

Hyperlink – Not needed for this application 

Identify – Enables users to point to a feature and get the attributes 

Fixed Zoom In – Zooms the map in by a factor of 2 

 
 



6 Working with the APSI in ArcMap 
Below are instructions for common functions you might want to perform in the application. 

6.1 Export Spatial Data Locally  
1. Right click the Layer you are interested in and select Data->Export Data 
2. Once the Export Data Window pops up you can either export the whole Layer and all its 

features or just selected features you can see in the View Extent. 
3. Note: It is best to use this function in conjunction with a selection, which is described 

below. 

6.2 Retrieving Information 
 
When you right mouse click on a layer, you can access the option “Open Attribute Table”. This 
opens all the data associated with that dataset. A table is setup similarly to a table in excel in 
terms of sorting. However, data is called a “record” and columns are called “fields”.  Right 
mouse click on a column title provides sorting, properties and more options.  The bottom of the 
table box provides movement among the records, displays total amount of records, and displays 
how many records are selected.  

 
Note: Most project codes are separated by hyphens in the name and documented with a state 
and year code.  For instance, CO-80-FC stands for Colorado 1980. 

 
 

6.3 Selecting Features 
 
You can perform two types of selections; either by spatial or attribute; both are described below.   

6.3.1 Making a Selection with the Select Feature Tool 

Use the Select Feature Tool  from the Tools toolbar and click on the map, a boundary will 
become highlighted in light blue. You can also draw a box by clicking the mouse, holding, and 



dragging; select an individual object with a single click; or select multiple objects by clicking 
while holding down the shift key. Now look at the table and if you click on the “Selected” 
button at the bottom of the table, the corresponding data row will also display in light blue.  
 

 
Seeing the connection between the ArcMap window and a database table note the selected item 

in the map and table are highlighted in blue. 
 
The same can be done if a row, or several rows (using the Ctrl key) are highlighted in the table. 
Their corresponding geographic boundaries in the Map Window will be highlighted.  
This helps select out all images of a particular state or a selection that can be gathering simply 
by sorting the table. 

6.3.2 Making a Selection with the Selection Query Tool 
• Look for the Selection->Select by 

Attribute drop down menu at the top 
menu bar. It is above the Table of 
Contents and Map Window.  

• Layer: must be on the layer you want 
to query data from. e.g. 
AIRPHOTO.PROJECTBOUNDAR
YS layer 

• Method: Create a new selection. 
(There are three more options you 
can explore further and are not 
discussed in this paper). 

• The listbox below the Method s
will display fields from the 
AIRPHOT.PROJECTBOUNDARYS 
table.  

ection 

• Double click the field name you want 
to inquire upon. e.g. 
PROJECT_CODE 



• If you click on the “Get Unique Values” button, only the records from that table will 
display. 

• Fill in your query by double-clicking your options and click, Apply. 
• If you click the “Selected” button at the bottom of the 

AIRPHOTO_PROJECTBOUNDARYS table, the query item will display. 

6.3.3 Notes on Performing a Selection 
 

• You can also Zoom to selected features by going to the top Menu Bar and going to 
Selection-> Zoom to Selected Features.  The map window will be zoomed to the extent 
of all features highlighted in light blue.  

• You can also use the Find Tool to make selections. If you use the Binoculars Tool  
from the Tools toolbar a Find window will pop up.  

6.4 Exporting a Table 
1. Right Click the Layer whose attributes you want to export. 
2. Select Open Attribute Table. 
3. Once in the Attribute Table, you can view only Selected records or All records by 

clicking one of the two ‘Show:’ buttons.   
4. Selected feature appear in light blue 
5. Go to Options->Export… and save the file.  You have the option of several file formats, 

but the two easiest to work with are either text or DBF file. Both file types can be easily 
opened with Excel.  Note that if there is a selection made only those selected features will 
be exported. 
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